<!doctype html>
<html>
    <head>
        <meta charset="UTF-8" />
        <title>Meghan Trainor Announces &#8216;A Very Trainor Christmas&#8217; Album &#x2d; Idolator</title>

        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
        <meta name="viewport" content="width=device-width">

        <link rel="alternate" type="application/rss+xml" title="RSS" href="https://www.idolator.com/feed">
        
        <script type="text/javascript" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js" async></script>
<script type='text/javascript'>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</script>
<script type='text/javascript'>(function(){_WF = window._WF || {};_WF.ab_overrides = _WF.ab_overrides || {};_WF.ab_overrides['csplit_ab'] = "control-1";_WF.ab_overrides['dynamic_ab'] = "control-1";})();</script><script type='text/javascript' src='https://www.idolator.com/wp-content/plugins/outrigger/scripts/vendor/header.js?ver=1599686928'></script>
<script type='text/javascript'>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</script><style>
    .as-oil {
        display: none;
    }

    button.as-oil__btn-optin {
        /* background-color : #FF3; */
        background-color: #004bb7;
        color: #ffffff;
        /* color: #1e5765; */
        width: 100%;
    }

    button.as-oil__btn-optin:hover {
        /* background-color : #FF3; */
        background-color: #004bb7;
        color: #ffffff;
        /* color: #1e5765; */
    }

    div.as-oil-l-row {
        float: right;
        margin: 0;
    }

    button.as-oil__btn-cpc {
        width: 100%;
        border-bottom: 0px;
    }

    div.as-oil-content-overlay {
        padding: 12px;
    }

    div#as-oil-cpc {
        visibility: hidden;
    }

    label.as-oil-cpc__switch span.as-oil-cpc__slider {
        background-color: #efd1d1 !important;
    }

    label.as-oil-cpc__switch input:checked~.as-oil-cpc__slider {
        background-color: #c2e0c2 !important;
    }
</style>
<script>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</script>
<script type='text/javascript'>
(function(){
var tagman = _WF.cache.getItem(_WF.KEYS.TAGMAN);
tagman.ab_allocation = {"version":"134","ab_tests":[]};
_WF.emit(_WF.EVENTS.AB);
if(true === false) {
    _WF.cache.setItem(_WF.KEYS.MABDATA, []);
    _WF.emit(_WF.EVENTS.MAB);
}
})();
</script>

<script type='text/javascript'>
(function(){

_WF.cache.setItem(_WF.KEYS.MABDATA, []);
_WF.emit(_WF.EVENTS.MAB);

})();
</script>

<script type='text/javascript'>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</script>

<script type='text/javascript'>
(function(){
_WF.cache.setItem(_WF.KEYS.PROVIDERS, {"base":{"multi_ypix":"yahoo_pixel","multi_ypix_2":"yahoo_pixel_2","multi_ypix_il":"yahoo_pixel_il","multi_snpixel":[{"when":{"deviceType":["mobile"],"tag":"snap_pixel"}}],"multi_trusignal":"trusignal","multi_tbpix":"taboola_pixel","multi_fbpix":"facebook_pixel","multi_fbpix_sp":[{"when":{"is_single_page_layout":["true"],"tag":"facebook_pixel_sp"}}],"multi_newrelic":"newrelic_by_source","multi_obpixel":"outbrain_pixel","multi_rcpixel":[{"when":{"utm_source":["rc"],"tag":"revcontent_pixel"}}],"multi_zmpixel_d20":[{"when":{"utm_source":["oz"],"tag":"zemanta_pixel_d20"}}],"multi_zmpixel_m7":[{"when":{"utm_source":["oz"],"tag":"zemanta_pixel_m7"}}],"multi_ldpixel":[{"when":{"utm_source":["ld"],"tag":"lockerdome_pixel"}}],"multi_fbpix_site":"facebook_pixel_site","multi_gdn_pixel":"adwords_gtm_dn","sp1":"prebidv2","sp3":[{"when":{"is_quiz":["true"],"tag":"none"}},{"when":{"utm_source":["*"],"tag":"prebidv2"}}],"sp5":[{"when":{"is_quiz":["true"],"tag":"none"}},{"when":{"utm_source":["*"],"tag":"prebidv2"}}],"put":[{"when":{"is_influencer":["true"],"tag":"none"}},{"when":{"utm_source":["*"],"tag":"prebidv2"}}],"pon":"prebidv2","pot":[{"when":{"deviceType":["mobile","tablet"],"tag":"prebidv2"}},{"when":{"is_quiz":["true"],"tag":"prebidv2"}}],"multi_nativo":[{"when":{"is_single_page_layout":["true"],"tag":"none"}},{"when":{"deviceType":["mobile","tablet"],"tag":"nativo"}}],"pon2":[{"when":{"utm_source":["tw","td"],"tag":"prebidv2"}}],"pon3":[{"when":{"utm_source":["tw","td"],"tag":"prebidv2"}}],"pun":[{"when":{"utm_source":["tw","td"],"tag":"prebidv2"}}],"poh2":[{"when":{"is_influencer":["true"],"tag":"prebidv2"}},{"when":{"deviceType":["mobile","tablet"],"tag":"none"}},{"when":{"utm_source":["tw","td"],"tag":"prebidv2"}}],"qp1":[{"when":{"is_fb_layout":["true"],"tag":"none"}},{"when":{"is_influencer":["true"],"tag":"none"}},{"when":{"utm_source":["tw","td"],"tag":"none"}},{"when":{"utm_source":["*"],"tag":"prebidv2"}}],"sp2":[{"when":{"is_quiz":["true"],"tag":"prebidv2"}},{"when":{"utm_source":["tw","td"],"tag":"none"}},{"when":{"utm_source":["*"],"tag":"facebook"}}],"poh1":[{"when":{"is_influencer":["true"],"tag":"prebidv2"}}],"poh3":[{"when":{"is_433_influencer":["true"],"tag":"prebidv2"}}],"pui0":[{"when":{"is_influencer":["true"],"tag":"none"}},{"when":{"deviceType":["mobile","tablet"],"tag":"prebidv2"}}],"pui1":[{"when":{"is_fb_layout":["false"],"tag":"none"}},{"when":{"is_single_page_layout":["true"],"tag":"none"}},{"when":{"deviceType":["tablet"],"tag":"prebidv2"}}],"poi":[{"when":{"utm_source":["tt"],"tag":"none"}},{"when":{"is_single_page_layout":["true"],"tag":"none"}},{"when":{"deviceType":["mobile","tablet"],"tag":"prebidv2"}}],"multi_avantis":[{"when":{"is_influencer":["true"],"tag":"none"}},{"when":{"is_single_page_layout":["true"],"tag":"none"}},{"when":{"deviceType":["desktop","tablet"],"tag":"none"}},{"when":{"utm_source":["s1","s2","lz","ns","lk"],"tag":"none"}},{"when":{"is_quiz":["true"],"tag":"none"}},{"when":{"deviceType":["mobile"],"tag":"avantis_multi"}}],"poh4":[{"when":{"is_433_influencer":["true"],"tag":"prebidv2"}}],"ilt":"prebidv2","ilb":"prebidv2","ip2":"prebidv2","ip3":"prebidv2","multi_yapix":"yahoo_pixel","ip1":"prebidv2","plb":"prebidv2","tp2":[{"when":{"is_organic":["true"],"tag":"pubexchange_widget"}}],"tp4":"none","lp1":[{"when":{"is_quiz":["true"],"tag":"none"}},{"when":{"is_fb_layout":["true"],"tag":"prebidv2"}}],"anc1":[{"when":{"deviceType":["desktop"],"tag":"none"}},{"when":{"utm_source":["st"],"tag":"prebidv2"}},{"when":{"is_influencer":["true"],"tag":"none"}},{"when":{"is_fb_layout":["true"],"tag":"none"}},{"when":{"is_quiz":["true"],"tag":"none"}},{"when":{"deviceType":["mobile","tablet"],"tag":"prebidv2"}}]},"overrides":{"qp1":"organic","qp2":"organic","sp5":"override_mobile","pui0":"organic","pui1":"organic","multi_nativo":"nativo_ab_override","lp1":"override_mobileorganic","anc1":"override_limited","poi":"organic","tp2":"organic","tp1":[{"when":{"utm_source":["fb","fs","kw"],"tag":"none"}},{"when":{"utm_source":["*"],"tag":"organic"}}],"multi_sublimeskinz":"organic"}});

})();
</script>

<script type='text/javascript'>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</script>

<script type='text/javascript'>
(function(){
var discounts = {};
discounts.functions = {
    flat : function(amount){
        return function(bid){
            return bid - amount;
        }
    },
    percent : _WF.utils.hbDiscountTo
};
discounts.bidderSettings = { "aol" : {
                            "bidCpmAdjustment" : discounts.functions.percent(.87)
                        },"appnexusAst" : {
                            "bidCpmAdjustment" : discounts.functions.percent(.99)
                        },"brealtime" : {
                            "bidCpmAdjustment" : discounts.functions.percent(.85)
                        },"defymedia" : {
                            "bidCpmAdjustment" : discounts.functions.percent(0.82)
                        },"openx" : {
                            "bidCpmAdjustment" : discounts.functions.percent(1)
                        },"pulsepoint" : {
                            "bidCpmAdjustment" : discounts.functions.percent(.95)
                        },"sharethrough" : {
                            "bidCpmAdjustment" : discounts.functions.percent(.77)
                        },"indexExchange" : {
                            "bidCpmAdjustment" : discounts.functions.percent(.99)
                        },"rubicon" : {
                            "bidCpmAdjustment" : discounts.functions.percent(1)
                        },"pubmatic" : {
                            "bidCpmAdjustment" : discounts.functions.percent(.94)
                        },"audienceNetwork" : {
                            "bidCpmAdjustment" : discounts.functions.percent(1)
                        },"sonobi" : {
                            "bidCpmAdjustment" : discounts.functions.percent(.89)
                        },"districtmDMX" : {
                            "bidCpmAdjustment" : discounts.functions.percent(.87)
                        },"triplelift" : {
                            "bidCpmAdjustment" : discounts.functions.percent(1)
                        },"tripleliftdisplay" : {
                            "bidCpmAdjustment" : discounts.functions.percent(0.99)
                        } };
;
_WF.cache.setItem(_WF.KEYS.DISCOUNTS, discounts);
})();
</script>
<script>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</script>
<!-- The SEO Framework by Sybre Waaijer -->
<meta name="robots" content="max-snippet:-1,max-image-preview:standard,max-video-preview:-1" />
<meta name="description" content="Meghan Trainor will release her first festive album, &#8216;A Very Trainor Christmas,&#8217; on October 30." />
<meta property="og:image" content="https://www.idolator.com/wp-content/uploads/sites/10/2020/09/meghan-trainor-christmas-album-18218.jpg" />
<meta property="og:image:width" content="620" />
<meta property="og:image:height" content="413" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Meghan Trainor Announces &#8216;A Very Trainor Christmas&#8217; Album" />
<meta property="og:description" content="Meghan Trainor will release her first festive album, &#8216;A Very Trainor Christmas,&#8217; on October 30." />
<meta property="og:url" content="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" />
<meta property="og:site_name" content="idolator" />
<meta property="fb:app_id" content="739634186231823" />
<meta property="article:published_time" content="2020-09-09T19:06+00:00" />
<meta property="article:modified_time" content="2020-09-09T19:06+00:00" />
<meta property="og:updated_time" content="2020-09-09T19:06+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Meghan Trainor Announces &#8216;A Very Trainor Christmas&#8217; Album" />
<meta name="twitter:description" content="Meghan Trainor will release her first festive album, &#8216;A Very Trainor Christmas,&#8217; on October 30." />
<meta name="twitter:image" content="https://www.idolator.com/wp-content/uploads/sites/10/2020/09/meghan-trainor-christmas-album-18218.jpg" />
<meta name="twitter:image:width" content="620" />
<meta name="twitter:image:height" content="413" />
<link rel="canonical" href="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.idolator.com/","name":"Idolator"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.idolator.com/category/headlines","name":"Headlines"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album","name":"Meghan Trainor Announces &#8216;A Very Trainor Christmas&#8217; Album"}}]}</script>
<!-- / The SEO Framework by Sybre Waaijer | 0.18ms meta | 0.31ms boot -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<!-- hive-theme-extras --><script type="application/ld+json">{"@context":"https://schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album?view-all"},"headline":"Meghan Trainor Announces &#8216;A Very Trainor Christmas&#8217; Album","image":{"@type":"ImageObject","url":"https://www.idolator.com/wp-content/uploads/sites/10/2020/09/meghan-trainor-christmas-album-18218.jpg","width":620,"height":413},"datePublished":"2020-09-09T19:06:38+00:00","dateModified":"2020-09-09T19:06:38+00:00","author":{"@type":"Person","name":"Mike Wass"},"publisher":{"@type":"Organization","name":"Idolator","url":"https://www.idolator.com","logo":{"@type":"ImageObject","url":"https://www.idolator.com/wp-content/uploads/sites/10/2020/04/cropped-onsite-idolator-cropped-favicon-39786-92154.png","width":512,"height":512}},"description":"Meghan Trainor will release her first festive album, &#8216;A Very Trainor Christmas,&#8217; on October 30."}</script><!-- end hive-theme-extras --><link rel='stylesheet' id='googleFontsArvo-css'  href='https://fonts.googleapis.com/css?family=Arvo%3ABold%2CBoldItalic%2CItalic%2CRegular&#038;ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='googleFontsOpenSansCondensed-css'  href='https://fonts.googleapis.com/css?family=Open+Sans+Condensed%3A300%2C300italic%2C700&#038;ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='idolator-css'  href='https://www.idolator.com/wp-content/themes/idolator/style.css?ver=1595959772' type='text/css' media='all' />
<script type='text/javascript' src='https://www.idolator.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.idolator.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel="apple-touch-icon" sizes="180x180" href="/wp-content/uploads/sites/10/fbrfg/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/wp-content/uploads/sites/10/fbrfg/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/wp-content/uploads/sites/10/fbrfg/favicon-16x16.png">
<link rel="manifest" href="/wp-content/uploads/sites/10/fbrfg/site.webmanifest">
<link rel="shortcut icon" href="/wp-content/uploads/sites/10/fbrfg/favicon.ico">
<meta name="msapplication-TileColor" content="#da532c">
<meta name="msapplication-config" content="/wp-content/uploads/sites/10/fbrfg/browserconfig.xml">
<meta name="theme-color" content="#ffffff"><!-- Begin comScore Tag -->
<script>
_WF.on(_WF.EVENTS.SETUP, function(){
  if (!_WF.utils.isMonetizationBlacklisted()) {
    var _comscore = _comscore || [];
    _comscore.push({ c1: "2", c2: "22453632", c4: encodeURIComponent(window.location.href) });
    (function() {
      var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
      s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
      el.parentNode.insertBefore(s, el);
    })();
  }
});
</script>
<noscript>
  <img src="//b.scorecardresearch.com/p?c1=2&c2=22453632&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->    </head>
    <body class="post-template-default single single-post postid-7914244 single-format-image idolator">

        <div id="menu" class="navbar navbar-default navbar-fixed-top" role="navigation">
            <div class="container">
                <div class="inner-nav-holder">

                    <div class="navbar-header">
                        <a href="/" class="navbar-brand" id="logo">
                            <img src="https://www.idolator.com/wp-content/themes/idolator/images/logo.png" width="280" height="40">
                        </a>
                        <span class="icon-menu" id="menu-toggle"></span>
                    </div>

                    <div class="navbar-collapse">
                                    <ul  id="menu-main-nav"   class="main-nav nav navbar-nav">
                            <li >
                            <a href="https://www.idolator.com/category/music-news/"  >Music News</a>
                
            </li>	
            <li >
                            <a href="https://www.idolator.com/category/gallery/"  >Photos</a>
                
            </li>	
            <li >
                            <a href="https://www.idolator.com/category/video/"  >Video</a>
                
            </li>	
            <li >
                            <a href="https://www.idolator.com/category/lists/"  >Lists</a>
                
            </li>	
            <li >
                            <a href="https://www.idolator.com/category/album-review/"  >Reviews</a>
                
            </li>
                
            </ul>
                        <div class="social-and-search">

                                        <ul    class="social social-links">
                            <li >
                            <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idolator.com%2F7914244%2Fmeghan-trainor-announces-a-very-trainor-christmas-album%3Futm_source%3Dshare-facebook%26utm_content%3Dfacebook%26utm_medium%3Dheadernav%26utm_campaign%3Dshare-headernav" class="icon-facebook" target="_blank"><i class="icon facebook"></i></a>
                
            </li>	
            <li >
                            <a href="https://www.instagram.com/idolator" class="icon-instagram" target="_blank"><i class="icon instagram"></i></a>
                
            </li>	
            <li >
                            <a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.idolator.com%2F7914244%2Fmeghan-trainor-announces-a-very-trainor-christmas-album%3Futm_source%3Dshare-pinterest%26utm_content%3Dpinterest%26utm_medium%3Dheadernav%26utm_campaign%3Dshare-headernav&media=https://www.idolator.com/wp-content/uploads/sites/10/2020/09/meghan-trainor-christmas-album-18218.jpg&description=Meghan+Trainor+Announces+%27A+Very+Trainor+Christmas%27+Album" class="icon-pinterest" target="_blank"><i class="icon pinterest"></i></a>
                
            </li>	
            <li >
                            <a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.idolator.com%2F7914244%2Fmeghan-trainor-announces-a-very-trainor-christmas-album%3Futm_source%3Dshare-twitter%26utm_content%3Dtwitter%26utm_medium%3Dheadernav%26utm_campaign%3Dshare-headernav" class="icon-twitter" target="_blank"><i class="icon twitter"></i></a>
                
            </li>
                
            </ul>
                            <div class="search">
                                <form role="search" action="/" method="GET" id="header-search">
    <div class="query-holder">
        <input type="text" name="s" placeholder="Search" autocomplete="off">
    </div>
    <span class="search-submit" id="search-submit"></span>
</form>                            </div>
                        </div>
                        
                    </div>
                    
                </div>
            </div>
                        <div class="menu-footer mobile-only">
                <ul class="clearfix">
                    <li>
                        <a href="https://www.idolator.com/privacy/" rel="nofollow" target="_blank">Privacy</a>
                    </li>
                    <li>
                        <a href="https://www.idolator.com/terms/" rel="nofollow" target="_blank">Terms</a>
                    </li>
                    <li>
                        <a href="https://www.idolator.com/dmca/" rel="nofollow" target="_blank">Copyright</a>
                    </li>
                    <li>
                        <a href="https://www.idolator.com/contact-us/" rel="nofollow" target="_blank">Contact Us</a>
                    </li>
                </ul>
            </div>
        </div>

                    <div id="id_leaderboard-top-wrapper" class="ad-widget-wrapper primary-ad-wrapper container ad-container"><div id="id_leaderboard-top" class="primary-ad-widget"></div>                    </div>    <div class="main-wrapper">
		<div id="lefternary">
			<div id="lefternary-P1" class="lefternary-ad-widget"></div>
			<div id="lefternary-P2" class="lefternary-ad-widget"></div>
			<div id="lefternary-P3" class="lefternary-ad-widget"></div>
			<div id="lefternary-P4" class="lefternary-ad-widget"></div>
			<div id="lefternary-P5" class="lefternary-ad-widget"></div>
        </div>
        
        <div id="quaternary" class="extrude-area">
            <div id="quaternary-P1" class="quaternary-ad-widget"></div>
            <div id="quaternary-P2" class="quaternary-ad-widget"></div>
            <div id="quaternary-P3" class="quaternary-ad-widget"></div>
            <div id="quaternary-P4" class="quaternary-ad-widget"></div>
            <div id="quaternary-P5" class="quaternary-ad-widget"></div>
        </div>

        <div class="container main-container">
            <div class="row">

                
                    <div id="primary" class="col-sm-8 left-col">

                                            <div class="article-body">

                        
                            <div id="image-above"></div>

                            <div>
                                <div id="primary-over-title-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                                    <div id="primary-over-title" class="primary-ad-widget"></div>
                                </div>

                                <div class="title-holder clearfix">
                                    <div class="title left">
                                        <h1>Meghan Trainor Announces &#8216;A Very Trainor Christmas&#8217; Album</h1>
                                    </div>
                                </div>

                                <div id="primary-under-title-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                                    <div id="primary-under-title" class="primary-ad-widget no-shift-put"></div>
                                </div>

                                    <div class="author ">
         
            <a href="https://www.idolator.com/author/mike-wass/">Mike Wass</a>
                            <span class="twitter"><a href="https://twitter.com/mikewassmusic" class="twitter-handle" target="_blank">@mikewassmusic</a></span>
                            <span class="sep">|</span> 
        <span class="date" content="2020-09-09T15:06:38-04:00">September 9, 2020 3:06 pm</span>

            </div>
                                <div class="social-holder">
        <div class="social-icons">
        <ul class="social-container">
                                                <li class="email  sharrre" data-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-short-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-text="Meghan Trainor Announces A Very Trainor Christmas Album" >
                        <a href="mailto:?subject=Meghan Trainor Announces A Very Trainor Christmas Album&body=https%3A%2F%2Fwww.idolator.com%2F7914244%2Fmeghan-trainor-announces-a-very-trainor-christmas-album%3Futm_medium%3Dshare-btn%26utm_content%3Dshare-btn%26utm_campain%3Dshare-btn%26utm_source%3Dshare-email" target="_blank">
                            <span class="icon-social"></span>
                            <span class="sharrre-title desktop-only">Email</span>
                        </a>
                    </li>
                                    <li class="facebook  sharrre" data-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-short-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-text="Meghan Trainor Announces A Very Trainor Christmas Album" >
                        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idolator.com%2F7914244%2Fmeghan-trainor-announces-a-very-trainor-christmas-album%3Futm_medium%3Dshare-btn%26utm_content%3Dshare-btn%26utm_campain%3Dshare-btn%26utm_source%3Dshare-fb&picture=https%3A%2F%2Fwww.idolator.com%2Fwp-content%2Fuploads%2Fsites%2F10%2F2020%2F09%2Fmeghan-trainor-christmas-album-18218.jpg" target="_blank">
                            <span class="icon-social"></span>
                            <span class="sharrre-title desktop-only">Follow</span>
                        </a>
                    </li>
                                    <li class="twitter  sharrre" data-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-short-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-text="Meghan Trainor Announces A Very Trainor Christmas Album" >
                        <a href="https://twitter.com/intent/tweet?text=Meghan Trainor Announces A Very Trainor Christmas Album&url=https%3A%2F%2Fwww.idolator.com%2F7914244%2Fmeghan-trainor-announces-a-very-trainor-christmas-album%3Futm_medium%3Dshare-btn%26utm_content%3Dshare-btn%26utm_campain%3Dshare-btn%26utm_source%3Dshare-tw" target="_blank">
                            <span class="icon-social"></span>
                            <span class="sharrre-title desktop-only">Tweet</span>
                        </a>
                    </li>
                                    <li class="reddit  sharrre" data-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-short-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-text="Meghan Trainor Announces A Very Trainor Christmas Album" >
                        <a href="https://www.reddit.com/submit?title=Meghan Trainor Announces A Very Trainor Christmas Album&url=https%3A%2F%2Fwww.idolator.com%2F7914244%2Fmeghan-trainor-announces-a-very-trainor-christmas-album%3Futm_medium%3Dshare-btn%26utm_content%3Dshare-btn%26utm_campain%3Dshare-btn%26utm_source%3Dshare-reddit" target="_blank">
                            <span class="icon-social"></span>
                            <span class="sharrre-title desktop-only">Reddit</span>
                        </a>
                    </li>
                                    <li class="sms hidden sharrre" data-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-short-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-text="Meghan Trainor Announces A Very Trainor Christmas Album" >
                        <a href="sms:;body=Check out this article: https%3A%2F%2Fwww.idolator.com%2F7914244%2Fmeghan-trainor-announces-a-very-trainor-christmas-album%3Futm_medium%3Dshare-btn%26utm_content%3Dshare-btn%26utm_campain%3Dshare-btn%26utm_source%3Dshare-email" target="_blank">
                            <span class="icon-social"></span>
                            <span class="sharrre-title desktop-only"></span>
                        </a>
                    </li>
                                    </ul>
    </div>
</div>                            </div>
                        
                                                    <div id="image-below">    <div class="featured-embed-holder format-image">
        
            <div class="article-image-holder">
                    <div class="mainembed photoembed mainembed-left-col/large align-center">
        <div class="img-wrap">
            <picture>
                                    <source srcset="//www.idolator.com/wp-content/uploads/sites/10/2020/09/meghan-trainor-christmas-album-18218-480x320.jpg" media="(max-width: 481px)">
                                <img class="imageresource" src="//www.idolator.com/wp-content/uploads/sites/10/2020/09/meghan-trainor-christmas-album-18218-620x413.jpg" alt="">
            </picture>
        </div>
        <div class="credit-wrapper">
                            <div class="credit"><small>CREDIT:</small> Epic Records</div>
                    </div>
    </div>
            </div>

            </div></div>
                        
                        <div class="ad-holder mobile-only">
                            <!-- ad goes here -->
                        </div>

                        <div class="article-content-holder">

                            <div class="single-content-holder">
                                <div class="article-content">

			                        <div class="inner-entry-content cf">
                                        <div class="mainembed articleembed">
    <div class="related-article-wrap">
        <div class="title">
            <strong>
                <a href="https://www.idolator.com/7906273/album-review-meghan-trainors-treat-myself-was-worth-the-wait" title="Review: Meghan's 'Treat Myself'">Review: Meghan's 'Treat Myself'</a>
            </strong>
        </div>
        <div class="body">
            <a href="https://www.idolator.com/7906273/album-review-meghan-trainors-treat-myself-was-worth-the-wait" title="Review: Meghan's 'Treat Myself'">
                <img src="https://www.idolator.com/wp-content/uploads/sites/10/2019/11/Meghan-Trainor-Treat-Myself-Workin-On-It-89667-84x84.jpg" alt="Review: Meghan's 'Treat Myself'"/>
            </a>
            <div class="excerpt">
                <span>We review Meghan Trainor's long-awaited 'Treat Myself' album.</span>
                <div>
                    <a href="https://www.idolator.com/7906273/album-review-meghan-trainors-treat-myself-was-worth-the-wait"> MORE &gt;&gt;</a>
                </div>
            </div>
        </div>
    </div>
</div>
<p>It&#8217;s about to get merry! <strong>Meghan Trainor</strong> is releasing her first festive offering, <em>A Very Trainor Christmas</em>, on October 30. &#8220;NOTHING makes me happier than the holidays [with] my family,&#8221; the pop star captioned the suitably-jolly cover art. &#8220;This year has been difficult to say the least, so I&#8217;m tryna bring joy the best way I know how&#8230; with a Christmas album full of originals &#038; classics!&#8221; She joins <strong>Dolly Parton</strong> and <strong>Carrie Underwood</strong> (good company!), who have already announced seasonal albums.</p>
<p>Of course, <em>A Very Trainor Christmas</em> will be Meghan&#8217;s second release of 2020. She kicked off the year by dropping her oft-delayed third album. <a href="https://www.idolator.com/7906273/album-review-meghan-trainors-treat-myself-was-worth-the-wait?view-all"><em>Treat Myself</em></a> turned out to be well worth the wait, but, like a lot of projects released at the top of the year, it got lost in the mayhem that followed the initial outbreak of COVID-19. If you have the time, it&#8217;s well worth revisiting. <a href="https://www.idolator.com/7906117/the-pussycat-dolls-join-meghan-trainor-on-empowering-bop-genetics?view-all">&#8220;Genetics&#8221;</a> is a bop for the ages, while <a href="https://www.idolator.com/7912412/meghan-trainor-wants-to-make-you-dance">&#8220;Make You Dance&#8221;</a> is a feel-good banger of the highest caliber. See her announcement below. </p>
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/CE6mLGpH8kn/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:540px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;"> <a href="https://www.instagram.com/p/CE6mLGpH8kn/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank" rel="noopener noreferrer"> </p>
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div>
<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div>
</div>
<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<p></a> </p>
<p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/CE6mLGpH8kn/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank" rel="noopener noreferrer">ITS ABOUT TO BE #AVeryTrainorChristmas!!! &#x1f60d;&#x1f384;&#x1f381; NOTHING makes me happier than the holidays with my family! This year has been difficult to say the least, so I’m tryna bring joy the best way I know how&#8230;with a Christmas album full of originals and classics&#x1f609;! Coming out on October 30th!&#x1f389; &#x1f4f8; @ryan.trainor.</a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/meghan_trainor/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank" rel="noopener noreferrer"> Meghan Trainor</a> (@meghan_trainor) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-09-09T12:30:59+00:00">Sep 9, 2020 at 5:30am PDT</time></p>
</div>
</blockquote>
<p> <script async src="//www.instagram.com/embed.js"></script></p>
<p><em>Are you excited for Meghan&#8217;s new album? Let us know below, or by hitting us up on <a href="https://www.facebook.com/idolatordotcom?fref=ts" target="_blank" rel="noopener noreferrer">Facebook</a> and <a href="https://twitter.com/idolator" target="_blank" rel="noopener noreferrer">Twitter</a>!</em></p>
                                    </div>

                                </div>
                            </div>

                                            
                                <div id="primary-over-header-1-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                                    <div id="primary-over-header-1" class="primary-ad-widget iscrollpoh"></div>
                                </div>
                                <div id="primary-over-header-2-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                                    <div id="primary-over-header-2" class="primary-ad-widget iscrollpoh"></div>
                                </div>
                                <div id="primary-over-header-3-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                                    <div id="primary-over-header-3" class="primary-ad-widget iscrollpoh"></div>
                                </div>
                                <div id="primary-over-header-4-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                                    <div id="primary-over-header-4" class="primary-ad-widget iscrollpoh"></div>
                                </div>

                            
                            <div id="primary-under-image-P1-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                                <div id="primary-under-image-P1" class="primary-ad-widget iscrollpui"></div>
                            </div>
                            <div id="primary-under-image-P2-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                                <div id="primary-under-image-P2" class="primary-ad-widget iscrollpui"></div>
                            </div>
                            <div id="primary-under-image-P3-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                                <div id="primary-under-image-P3" class="primary-ad-widget iscrollpui"></div>
                            </div>
                            <div id="primary-under-image-P4-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                                <div id="primary-under-image-P4" class="primary-ad-widget iscrollpui"></div>
                            </div>

                            <div id="primary-over-paragraph-1-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                                <div id="primary-over-paragraph-1" class="primary-ad-widget iscrollpop"></div>
                            </div>
                            <div id="primary-over-paragraph-2-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                                <div id="primary-over-paragraph-2" class="primary-ad-widget iscrollpop"></div>
                            </div>
                            <div id="primary-over-paragraph-3-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                                <div id="primary-over-paragraph-3" class="primary-ad-widget iscrollpop"></div>
                            </div>
                            <div id="primary-over-paragraph-4-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                                <div id="primary-over-paragraph-4" class="primary-ad-widget iscrollpop"></div>
                            </div>

                            
                                    <div id="primary-over-next-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                        <div id="primary-over-next" class="primary-ad-widget"></div>
                    </div>
                    <div id="primary-over-next-container">
                        <div id="primary-over-next-P2-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                            <div id="primary-over-next-P2" class="primary-ad-widget"></div>
                        </div>
                        <div id="primary-over-next-P3-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                            <div id="primary-over-next-P3" class="primary-ad-widget"></div>
                        </div>
                    </div>

                    <div class="sp-pagination row desktop-only">
                                                    <div class="col-sm-4 prev inactive">
                                                            </div>
                            <div class="current col-sm-4">
                                                            </div>
                                                
                        <div id="next-button" class="col-sm-4 next ">
                            <a class="next-article" href="https://www.idolator.com/7914241/ingrid-andress-covers-dua-lipas-dont-start-now">Next Article <div class="pag-arrow"><span class="icon-chevron-light-right"></span></div></a>                        </div>
                    </div>

                    
                        <div class="navigation sp-pagination cols mobile-only">
                            <a class="next-article" href="https://www.idolator.com/7914241/ingrid-andress-covers-dua-lipas-dont-start-now">Next Article <div class="pag-arrow"><span class="icon-chevron-light-right"></span></div></a>                        </div>

                    
                    <div id="primary-under-next-wrapper" class="ad-widget-wrapper primary-ad-wrapper">
                        <div id="primary-under-next" class="primary-ad-widget"></div>
                    </div>

                
                            <div class="row tags-and-comments desktop-only">
                                <div class="col-sm-9">
                                    <div class="tags">
                                        <strong>Tags:</strong> <a href="https://www.idolator.com/tag/meghan-trainor" rel="tag">Meghan Trainor</a>                                    </div>
                                </div>
                            </div>
                        </div>

                        <div class="social-holder clearfix mobile-only">
                            <div class="social-holder">
        <div class="social-icons">
        <ul class="social-container">
                                                <li class="email  sharrre" data-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-short-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-text="Meghan Trainor Announces A Very Trainor Christmas Album" >
                        <a href="mailto:?subject=Meghan Trainor Announces A Very Trainor Christmas Album&body=https%3A%2F%2Fwww.idolator.com%2F7914244%2Fmeghan-trainor-announces-a-very-trainor-christmas-album%3Futm_medium%3Dshare-btn%26utm_content%3Dshare-btn%26utm_campain%3Dshare-btn%26utm_source%3Dshare-email" target="_blank">
                            <span class="icon-social"></span>
                            <span class="sharrre-title desktop-only">Email</span>
                        </a>
                    </li>
                                    <li class="facebook  sharrre" data-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-short-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-text="Meghan Trainor Announces A Very Trainor Christmas Album" >
                        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idolator.com%2F7914244%2Fmeghan-trainor-announces-a-very-trainor-christmas-album%3Futm_medium%3Dshare-btn%26utm_content%3Dshare-btn%26utm_campain%3Dshare-btn%26utm_source%3Dshare-fb&picture=https%3A%2F%2Fwww.idolator.com%2Fwp-content%2Fuploads%2Fsites%2F10%2F2020%2F09%2Fmeghan-trainor-christmas-album-18218.jpg" target="_blank">
                            <span class="icon-social"></span>
                            <span class="sharrre-title desktop-only">Follow</span>
                        </a>
                    </li>
                                    <li class="twitter  sharrre" data-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-short-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-text="Meghan Trainor Announces A Very Trainor Christmas Album" >
                        <a href="https://twitter.com/intent/tweet?text=Meghan Trainor Announces A Very Trainor Christmas Album&url=https%3A%2F%2Fwww.idolator.com%2F7914244%2Fmeghan-trainor-announces-a-very-trainor-christmas-album%3Futm_medium%3Dshare-btn%26utm_content%3Dshare-btn%26utm_campain%3Dshare-btn%26utm_source%3Dshare-tw" target="_blank">
                            <span class="icon-social"></span>
                            <span class="sharrre-title desktop-only">Tweet</span>
                        </a>
                    </li>
                                    <li class="reddit  sharrre" data-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-short-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-text="Meghan Trainor Announces A Very Trainor Christmas Album" >
                        <a href="https://www.reddit.com/submit?title=Meghan Trainor Announces A Very Trainor Christmas Album&url=https%3A%2F%2Fwww.idolator.com%2F7914244%2Fmeghan-trainor-announces-a-very-trainor-christmas-album%3Futm_medium%3Dshare-btn%26utm_content%3Dshare-btn%26utm_campain%3Dshare-btn%26utm_source%3Dshare-reddit" target="_blank">
                            <span class="icon-social"></span>
                            <span class="sharrre-title desktop-only">Reddit</span>
                        </a>
                    </li>
                                    <li class="sms hidden sharrre" data-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-short-url="https://www.idolator.com/7914244/meghan-trainor-announces-a-very-trainor-christmas-album" data-text="Meghan Trainor Announces A Very Trainor Christmas Album" >
                        <a href="sms:;body=Check out this article: https%3A%2F%2Fwww.idolator.com%2F7914244%2Fmeghan-trainor-announces-a-very-trainor-christmas-album%3Futm_medium%3Dshare-btn%26utm_content%3Dshare-btn%26utm_campain%3Dshare-btn%26utm_source%3Dshare-email" target="_blank">
                            <span class="icon-social"></span>
                            <span class="sharrre-title desktop-only"></span>
                        </a>
                    </li>
                                    </ul>
    </div>
</div>                        </div>
                    </div>

                    <hr class="desktop-only">
                    </div>

                
<script type='text/javascript'>
(function(){

var allowPartialMatch = true;

function createMainAdPlacement(id, position){
    var main = document.querySelector("main");
    var div = document.createElement("div");
    div.id = id;
    position(main, div);
    _WF.utils.setStyles(div, {
        "left" : 0,
        "right" : 0,
        "margin-left" : "auto",
        "margin-right" : "auto",
        "margin-top" : "8px",
        "margin-bottom" : "24px"
    });
}

function setStyles(size){
    return function(placement){
        if (placement){
            var style = { "width" : "970px" };
            if (placement.atf){
                style["min-height"] = size;
            }
            _WF.utils.setStyles(placement.el, style);
        }
    };
}

function setMainPlacementSize(size){
    var placements = [];
    if (placementIsActive("lbt")){
        placements.push({ el : document.getElementById("leaderboard-top"), atf: true});
    }
    if (placementIsActive("lbb")){
        placements.push({ el : document.getElementById("leaderboard-bottom"), atf: false});
    }
    placements.map(setStyles(size));
}

function placementIsActive(abbr){
    var placementIsActive = false;
    var stm_providers = _WF.cache.getItem(_WF.KEYS.PROVIDERS);
    if (stm_providers[abbr] && stm_providers[abbr].indexOf("prebidv2") > -1){
        placementIsActive = true;
    }
    return placementIsActive;
}

_WF.where.testing("wideleader_ab", function(){
    if (placementIsActive("lbt")){
        createMainAdPlacement("leaderboard-top", function(peg, el){
            peg.parentNode.insertBefore(el, peg);
        });
    }
}, "header", allowPartialMatch);

_WF.where.testing("wideleader_ab", function(){
    if (placementIsActive("lbb")){
        createMainAdPlacement("leaderboard-bottom", function(peg, el){
            peg.parentNode.insertBefore(el, peg.nextElementSibling);
        });
    }
}, "footer", allowPartialMatch);

_WF.where.testing("wideleader_ab", function(){
    setMainPlacementSize("90px");
}, "90px", allowPartialMatch);

_WF.where.testing("wideleader_ab", function(){
    setMainPlacementSize("250px");
}, "250px", allowPartialMatch);
})();
</script>

                <div class="col-sm-4 sidebar">
                            <aside id="secondary" class="widget-area content-border-color">
            <div id="secondary-P0-wrapper" class="ad-widget-wrapper secondary-ad-wrapper">
                <div id="secondary-P0" class="secondary-ad-widget"></div>
            </div>
            <div id="secondary-P1-wrapper" class="ad-widget-wrapper secondary-ad-wrapper">
                <div id="secondary-P1" class="secondary-ad-widget"></div>
            </div>
            <div id="secondary-P2-wrapper" class="ad-widget-wrapper secondary-ad-wrapper">
                <div id="secondary-P2" class="secondary-ad-widget"></div>
            </div>
            <div id="secondary-P3-wrapper" class="ad-widget-wrapper secondary-ad-wrapper">
                <div id="secondary-P3" class="secondary-ad-widget"></div>
            </div>
        </aside><!-- #secondary -->
    <div id="sidebar"></div>

        <aside id="secondary-2" class="widget-area content-border-color">
            <div id="secondary-P4-wrapper" class="ad-widget-wrapper secondary-ad-wrapper">
                <div id="secondary-P4" class="secondary-ad-widget"></div>
            </div>
            <div id="secondary-P5-wrapper" class="ad-widget-wrapper secondary-ad-wrapper">
                <div id="secondary-P5" class="secondary-ad-widget"></div>
            </div>
            <div id="secondary-P6-wrapper" class="ad-widget-wrapper secondary-ad-wrapper">
                <div id="secondary-P6" class="secondary-ad-widget"></div>
            </div>
        </aside><!-- #secondary-2 -->                </div>

                <div class="doodad-alignment col-sm-8 left-col">
                    <div id="tertiary">
                        <div id="tertiary-P1" class="tertiary-ad-widget"></div>
                        <div id="tertiary-P2" class="tertiary-ad-widget"></div>
                        <div id="tertiary-P3" class="tertiary-ad-widget"></div>
                        <div id="tertiary-P4" class="tertiary-ad-widget"></div>
                        <div id="tertiary-P5" class="tertiary-ad-widget"></div>
                    </div>
                </div>

            </div>
        </div>
    </div>

        <div class="leaderboard-wrap">
            <div class="container leaderboard-container">
                    <div id="id_leaderboard-bottom-lazy-wrapper" class="ad-widget-wrapper primary-ad-wrapper container ad-container"><div id="id_leaderboard-bottom-lazy" class="primary-ad-widget"></div>                </div>
            </div>
        </div>

            
        <footer id="footer">
            <div class="container">
                <div class="comscore">
                    <div class="comscore-header clearfix">
                        <div class="right">
                            <div class="mobile-site-footer">
                            </div>
                            <div class="footer-logo">
                                <a href="/"><img src="https://www.idolator.com/wp-content/themes/idolator/images/logo-white.svg" width="188" height="30"></a>
                            </div>
                        </div>
                                                <div class="left">
                            <div class="comscore-header-links footer-links">
                                <a class="comscore--link comscore--header-link" href="https://www.idolator.com/terms/" rel="nofollow" target="_blank">Terms</a>
                                <a class="comscore--link comscore--header-link" href="https://www.idolator.com/privacy/" rel="nofollow" target="_blank">Privacy Policy</a>
                                <a class="comscore--link" href="https://www.idolator.com/dmca/" rel="nofollow" target="_blank">Copyright</a>
                                <a class="comscore--link" href="https://www.idolator.com/contact-us/" rel="nofollow" target="_blank">Contact Us</a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </footer>

        <script>(function () {var contentReadyFired = false;if(!contentReadyFired) {_WF.emit(_WF.EVENTS.CONTENTREADY);contentReadyFired = true;}})();</script><!-- Quantcast Tag -->
<script type="text/javascript">
_WF.on(_WF.EVENTS.SETUP, function(){
    var _qevents = _qevents || [];

    (function () {
        if (_WF.utils.isMonetizationBlacklisted()) {
            return;
        }
        var elem = document.createElement('script');
        elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
        elem.async = true;
        elem.type = "text/javascript";
        var scpt = document.getElementsByTagName('script')[0];
        scpt.parentNode.insertBefore(elem, scpt);
    })();

    _qevents.push({
        qacct: "p-sDavpVA1K-z6d"
    });
});
</script>

<noscript>
    <div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-sDavpVA1K-z6d.gif" border="0" height="1" width="1" alt="Quantcast" />
</div>
</noscript>
<!-- End Quantcast tag --><script>(function(){var cooKey = new RegExp("_ga(=)(.*?)($|;)");var gaCookieValue = (document.cookie.match(cooKey) || [])[2];var sessionDepth = _WF.utils.parseInt(_WF.cache.getItem(_WF.KEYS.SESSIONDEPTH));var gaIsReturn = sessionDepth === 1 && gaCookieValue ? true : false;var gaUserId = gaCookieValue ? gaCookieValue.split(".").splice(2).join(".") : "";var postAuthor = _WF.cache.getItem(_WF.KEYS.POSTAUTHOR) || {id: "", username: ""};/* Only run the method once */var sessionMessageAttempted = false;window.trySendSessionMessage = function () {try {if (sessionMessageAttempted || sessionDepth !== 1) {return;}sessionMessageAttempted = true;if (!gaUserId && ga) {ga(gaUserId = ga.getAll()[0].get('clientId'));}_WF.utils.trySendGASessionMessage(gaUserId, gaIsReturn);} catch (ex) {_WF.utils.trackGenericEvent("ga", "unable to get GA session", ex.message);}};(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m);})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");var lptwinner = _WF.cache.getItem(_WF.KEYS.LPTWINNER) ? JSON.parse(_WF.cache.getItem(_WF.KEYS.LPTWINNER)).id : "";ga("create", "UA-30043-18", "auto");ga("set", "dimension1", (_WF.cache.getItem(_WF.KEYS.SUBID) || ""));ga("set", "dimension2", (_WF.cache.getItem(_WF.KEYS.BUCKETID) || ""));ga("set", "dimension3", (_WF.cache.getItem(_WF.KEYS.DMC) || ""));ga("set", "dimension4", (_WF.cache.getItem(_WF.KEYS.PAGENUMBER) || ""));ga("set", "dimension5", lptwinner);ga("set", "dimension6", (_WF.cache.getItem(_WF.KEYS.POSTID) || ""));ga("set", "dimension7", (_WF.cache.getItem(_WF.KEYS.ADBLOCK) || ""));ga("set", "dimension8", (_WF.cache.getItem(_WF.KEYS.POSTABBR) || ""));ga("set", "dimension9", postAuthor.id);ga("set", "dimension10", postAuthor.username);ga("set", "dimension11", (_WF.cache.getItem(_WF.KEYS.RPS) || ""));ga("set", "userId", (_WF.cache.getItem(_WF.KEYS.UUID) || ""));ga("require", "linkid", {"cookieName": "_gale","duration": 30,"levels": 7});ga("send", "pageview", { "hitCallback": trySendSessionMessage });_WF.utils.setTimeout(trySendSessionMessage, 3000);})();</script><script type='text/javascript' async defer src='https://www.idolator.com/wp-content/plugins/outrigger/scripts/vendor/footer.js?ver=1599241939'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sidebar_info = {"ajaxurl":"https:\/\/www.idolator.com\/wp-content\/plugins\/wp-ajax\/endpoint.php","front":"","date":"","feed":"","author":"","search":"","archive":"","post_id":"7914244"};
/* ]]> */
</script>
<script type='text/javascript' defer async src='https://www.idolator.com/wp-content/themes/idolator/js/footer.js?ver=1594836067'></script>
<script type='text/javascript' defer async src='https://www.idolator.com/wp-content/themes/idolator/js/desktop.js?ver=1540491020'></script>
<script type='text/javascript' src='https://www.idolator.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.idolator.com/wp-content/plugins/featured-embed/js/slick.min.js?ver=1.6.0'></script>

    </body>
</html>